Results 1 to 2 of 2

Thread: Possible collision glitch?

  1. #1
    Junior Member
    Join Date
    Dec 2015
    Posts
    1

    Possible collision glitch?

    First off, just wanted to say I bought in to early access about a month or two ago, and I'm loving the game - keep up the awesome work!

    So, I was just playing the new Update 4.5 (0.1.11.20.15), doing the emergency docking mission. The first time, I got close, but had a few bumps that threw me off enough that I didn't manage before hitting the 30km mark.

    The second time, everything was going well, was in really close and all my position/rotation indicators were green. It is possible one of the locations drifted out of alignment a bit right at the end, but regardless, I definitely should have been moving very slowly relative to the station. I also had my emergency clamp primed. When I made contact, I heard a clunk, and thought that my clamp had engaged, but then noticed that the docking indicators were all spinning wildly. So I pitched up to see the station spinning away, it's rotation considerably faster than before (and in more than just the one axis), and moving away at... about 6m/s, I think it was (though I can't remember exactly).

    Even if I didn't get a lock, the effect this bump had on station seemed very disproportionate to how hard it seems I could possibly have hit it, especially considering I had given it a few bumps on my previous attempt (which I think must have hit harder than this time), which didn't seem to push it around anywhere near this much.

    Not exactly something I can easily reproduce at the moment, but since this update just added collisions back in, I figured I'd throw a post up in case it might help, or in case anyone else encounters this.

  2. #2
    Administrator
    Join Date
    Oct 2010
    Location
    Texas
    Posts
    2,119
    Thanks for the report. Since I'm not doing any sort of penetration management yet, my assumption will be the two ships intersected before the impact manager picked up the collision. This could create a disproportionately larger physics result than you would expect. Hopefully, once I implement that, this will fix itself.

    Any other problems, please feel free to continue to add to this thread.

    First off, just wanted to say I bought in to early access about a month or two ago, and I'm loving the game - keep up the awesome work!
    Thanks; and, thanks for your support!
    __________________
    "There is no spoon..."

Similar Threads

  1. Car is giving CTD - Collision Body Checksum
    By misterdave in forum Modding - Cars
    Replies: 6
    Last Post: 12-14-2017, 03:55 PM
  2. Collision issues in the cockpit
    By Kill3rCat in forum Rogue System Bug Reports
    Replies: 5
    Last Post: 07-28-2015, 07:01 PM
  3. Desactivate collision for some cars
    By Elthib in forum rFactor 1 General Discussion
    Replies: 0
    Last Post: 02-12-2014, 05:43 AM
  4. Collision bug.
    By BkS in forum Modding - Cars
    Replies: 7
    Last Post: 12-27-2013, 01:11 PM
  5. Vehicle Collision mismatch
    By Frank Geyer in forum rFactor 1 General Discussion
    Replies: 12
    Last Post: 07-16-2011, 01:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •