NOTICE Notice: This is an old thread and information may be out of date. The last post was 339 days ago. Please consider making a new thread.
Results 1 to 2 of 2

Thread: Crashing on Start Up

  1. #1
    Registered SL1DE's Avatar
    Join Date
    Jan 2012
    Posts
    41

    Crashing on Start Up

    I'm hoping someone here can figure this out. My rFactor installation has been working fine for years upon years, now all of a sudden WITHOUT CHANGING ANYTHING, it crashes as soon as I start it, after it shows that smaller square image when it's loading the game, and it goes into full screen mode to get into the actual game. I get the "rFactor has stopped working" thing.

    It's weird, and I know it's not my PC nor my new graphics card (Radeon RX 480) because I have another newer rFactor installation which still works fine.

    Here's my trace:
    About 10,000 lines of "setup.cpp 1892: Did not add vehicle GAMEDATA\VEHICLES\etc. (either because it did not pass filter or error)" for the VEH file of every single car I have, and
    gamestats.cp 906: RaceCast Location set to: racecast.rfactor.net
    plrfile.cpp 1727: Attempting to save to USERDATA\James\James.TMP
    plrfile.cpp 1757: Retcode: 0 for renaming to USERDATA\James\James.PLR
    RFETire.hpp 128: Dedicated instance not detected, assumming client.
    vidman.cpp 1229: Entered VidMan::Enter()

    I literally have not changed anything since last time I played, haven't even installed any new mods. So why is this happening?

    It would be a shame if I had to reinstall it, because as I've said I've had this installation for years since 2010 and since then I've built it up to a 100gb installation. I have almost every car and track you can think of and I don't have backups of the original archives they came in - Meaning I'll have to redownload them. Most of them the links probably won't even work anymore meaning they would be impossible to redownload.

    Edit: Trace after removing all driver profiles.
    TRACE LEVEL = 4
    NetComm.cpp 11193: NetComm checking command line: "trace=4"
    game.cpp 1211: Entered Game::Enter()
    osman.cpp 540: Entered OSMan::Enter()
    plrfile.cpp 2314: Entered PlayerFile::Enter()
    RFETire.hpp 128: Dedicated instance not detected, assumming client.
    NetComm.cpp 14056: NetComm: Error opening banlist xml file
    vidman.cpp 1229: Entered VidMan::Enter()

    Edit2: Replaced Plugins folder with Plugins folder from fresh install:
    TRACE LEVEL = 4
    NetComm.cpp 11193: NetComm checking command line: "trace=4"
    game.cpp 1211: Entered Game::Enter()
    osman.cpp 540: Entered OSMan::Enter()
    plrfile.cpp 2314: Entered PlayerFile::Enter()
    vidman.cpp 1229: Entered VidMan::Enter()

    So now there's less in my trace file, however it's still crashing.

    Edit3: Don't know what the problem was with my old installation, but I fixed it by creating a fresh installation and moving everything there. Weird that a fresh installation worked with the exact same files copied to it, however when I made a fresh installation and copied the fresh files to the old folder - That didn't work. Even though the two folders had the same files in them. Whatever is causing the old one to crash, isn't causing the new one to crash.
    Last edited by SL1DE; 12-14-16 at 06:49 AM.

  2. #2
    Registered Tripp's Avatar
    Join Date
    Dec 2010
    Location
    Sweden
    Posts
    278
    when was the install working fine what date easiest way is go back in time with the pc i have several problems with windows update that f.ks up my win 7 install
    start to search after other faults take and delete addons to rfcator RFE files can get odd things so the game not wanna start dll files can often mess up a game it have also happend that something with the files that lay in the root folder of rfactor do thgings so not rfactor start
    Java update for example do that rfdynhud not work
    i have several times delete rf1 installations and start over from fresh

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •