NOTICE Notice: This is an old thread and information may be out of date. The last post was 426 days ago. Please consider making a new thread.
Results 1 to 3 of 3

Thread: Can't fully disable cockpit head movement (Exaggerate Yaw="0.0000000119")

  1. #1
    New Member mrsh's Avatar
    Join Date
    Jul 2016
    Posts
    1

    Can't fully disable cockpit head movement (Exaggerate Yaw="0.0000000119")

    Hello,
    i got "everything" set to "0" but still (in HistoricGTTC1.96 G1-BMW CSL) there is head movement left/right when steering in cockpit view, minimal when car stopped, huge on speed.
    Is there a way to disable cockpit viewpoint movement w/o modifying car files, if not - which values of cockpit and headphysics files are related to this horizontal thing?
    How to completely disable "Exaggerate Yaw"? It resets from 0 to "0.0000000119" (firstly it changes from "0" to "0.0000", after re-run the game its "0.0000000119") and the cockpit viewpoint is never "calmed", even just after setting it to "0" in .plr or in Menu.
    I tried manually set in .plr "0" (resets to "0.0000000119") and also "-1" (resets to "-0.80", which is value equal to "-100%" setting in Menu)
    "0.0000000119" is small multiplier, but maybe not enough for settings of Historic cars.

    Here is my cfg:
    Leanahead Angle="0.00000"
    Lookahead Angle="0.00000"
    Head Physics="0.00000"
    Head Rotation="0.00000"
    Exaggerate Yaw="0.0000000119" // not able to set "0"

  2. #2
    Registered Lazza's Avatar
    Join Date
    Oct 2010
    Location
    Australia
    Posts
    3,452
    That's a very small number

    (to put it in context: if 1.0 meant turning your head 90 to the left/right, 0.0000000119 would be moving your line of sight by 1.86cm at a distance of 1km)

    Exaggerate yaw only moves your head left/right in reaction to lateral G forces, and obviously that very small value is going to be imperceptible. So something else is making your head move.

    Don't worry about the headphysics files, they're only for the graphical movement of the helmet I'm pretty sure. The .CAM files have some settings for each camera, I remember I sometimes edited the OrientationRate settings (in [COCKPIT], which was the view I used) to stop the camera moving around as much with some cars. You can lower the values to something like 10 or 20, you don't want 0 or the camera will literally not move from its original orientation even as the car rotates. (default for cockpit is usually 999, which in practice means it'll keep up with all applied movements)

    Been a long time since I played with this stuff, and I'm not sure your large camera movement (as described) isn't caused by something else, but I know I couldn't lock the camera movement to the car in rF1 so maybe give those .cam settings a go. You might need to adjust the values a little if you go too low, you'll notice the camera movement lagging behind the car. (the first value I think should be up/down rotation, second left/right, and third roll [which you stll don't want zero, or your head will stay straight when you're on ovals or otherwise cambered road])

  3. #3
    Registered MystaMagoo's Avatar
    Join Date
    Oct 2010
    Location
    UK
    Posts
    805
    maybe try this?

    Find this line under the camera you wish to adjust,
    OrientationRate=(999.000000, 999.000000, 999.000000)
    Your values may be different.
    Change the first variable to somewhere between 1 and 35

    it's more to keep horizon steady but may work for you?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •