View Full Version : runningh multiple servers

02-08-11, 02:18 PM
How can I run 2 or more servers on the same ip and have rfactor reconize the servers.

I and using server 1 with the standart ports as 34297 34397

and the secone servers starting ports of 35297 35397
i want to run 2 games per server 4 games total. matchmaker shows all the games being listed, but i get a timeed out on the sercond server.
I am behi9nd a filrewall and i have all the settings set... the only port can i increase by one 34447??? any help will be appreaceted

Noel Hibbard
02-08-11, 02:35 PM
Create driver profiles for each server. Name the first profile "mcopy Server1" and the second "mcopy Server2". Then for Server1 open the multiplayer.ini and set these lines:
Query Port Start="34297"
Port Start="34397"
Default Game Name="mcopy Server1"

For Server2 set:
Query Port Start="34298"
Port Start="34398"
Default Game Name="mcopy Server2"

Then create shurtcuts like this:
rFactor Dedicated.exe" +profile "mcopy Server1" +oneclick +fullproc
rFactor Dedicated.exe" +profile "mcopy Server2" +oneclick +fullproc

Then open these ports on your firewall:

TCP/UDP 34297 - 34298
UDP 34397 - 34398
TCP 34447 - 34448

Sounds to me like you haven't gotten all the correct ports mapped.

02-08-11, 03:27 PM
I have the
TCP/UDP 34297 - 34298
UDP 34397 - 34398
TCP 34447 - 34448
mapped in server1, in

TCP/UDP 33297 - 33298
UDP 33397 - 33398
TCP 34449 - 34450
Query Port Start="33297"
Port Start="33397"
mapped in server2, in

all are set in the multiplayer.cfg

i think its in the 34447 port not connecting, is their anyway to change that in any of the config files???

02-08-11, 05:22 PM
i think it might be the port forwarding that you havent got correct properly.

Noel Hibbard
02-09-11, 09:50 AM
Sorry, I didn't get detailed enough. I specified the range of ports to map for the two servers. Each server needs it's own "Query Port Start" and "Port Start". Even if these servers are running on separate computers (unless you do port translation on your firewall).

Server1 gets these ports:
TCP/UDP 34297
UDP 34397
TCP 34447

And these for server2:
TCP/UDP 34298
UDP 34398
TCP 34448

TBH I don't think 34447 and 34448 are even needed. I think I unmapped this port once and had some people connect and then went back to my firewall log and didn't see any attempts on that port. My guess is it isn't really used and I can't even recall where I got that port number from. But mapping it anyways isn't going to hurt anything.

02-10-11, 02:07 PM
Isn't "Port Start" means that game will try to assign each next connected player to next port?
If you define Port Start = 34297 for Server1 and 34298 for Server2, there will be ports conflicting. For example Server1 will immediately allocate port 34298 for the second connected driver making impossible S2 to work.

02-10-11, 03:04 PM
@MaXyM That's not how the port assignments work. The clients use the same port range.

02-10-11, 10:49 PM
the first computer is working fine with multiple mods, the second computer is listing the loaded mods in the rfactor lobby but when you connect to a mod it will give you a timed out... all ports are configured and passed thru the firewall. any ideas on the problem i will try anything... Thanks

Noel Hibbard
02-11-11, 07:19 PM
Are you trying to connect to this server from your local network? If so you have to change the list refresh type to LAN or else you will get the public IP of your server which isn't going to connect.

02-12-11, 09:46 PM
I cant connect local or thru the game on computer 2. No body outside my network can connect, all get Tiimed out on computer 2. lan/internet works fine on computer 1.

02-14-11, 12:54 AM
Ok, I have both servers, 2 different Servers (machines online, working. BUT i am having problems connecting 2 one thru the lan. Everyone is able to connect online now. Any suggestions how I can cionnect thru my network to both machines? Jeff

02-14-11, 12:55 AM
yes I did your suggestion and only one game came up. 4 are running...

Noel Hibbard
02-14-11, 02:30 PM
That is a bug and totally normal. Only servers running on 34297 show up when refresh list is set to LAN. The only way to connect is manually. For example for server one and for server two. Once you are connected you should bookmark the server so that next time you don't have to do it manually. To bookmark just click the little computer screen button which you will see at the bottom of the chat box between the Yes and No buttons. Once you click that you will see a bunch of options, one says bookmark. Once it is bookmarked you can click the friends tab and the server will show up on the list. BTW, you can change the refresh type back to Internet after you have bookmarked all you servers. This is a big time saver.

02-24-11, 11:16 AM
I know its the 34447 port that i need to configure for the second maching, is there anyway to add that port option in the config file? I can change the main port i think from 1100-54000 or something, both machines showup in match maker but when anyone lan or internet joins, it trys to tonnect to the 1st maching loaded. Thus giving the client a timed out mismatch error. I can connect thru the lan with No Problems. Buts it's that darn 44447 port. I incerments by 1 on the same maching but I need to start it at a higher value to have it error free on the second server. DOES ANYONE KNOW HOW TO CHANGE THIS VALUE? can I add a line of code? If so what is the code line and ill be right as rain. MCOPY

Noel Hibbard
02-24-11, 04:04 PM
If you set up your multiplayer.ini files as I instructed above, then server one should use 34447 and server two should use 34448 and so on and so on.

02-25-11, 05:35 PM
I use 2 PC one to drive rfactor with and Second PC to host servers to host many servers from pc 2 is another story because PC 1 ocuppied this ports
TCP/UDP 34297
UDP 34397
TCP 34447

I must start up 1 server on PC 2 like a ghost server it have same ports as my rfactor on PC 1 so i not klick that server to show in match maker all players get join time out on that server !!
Now i start the second dedicated this one people can join and then i can start up all servers i wanna have up.
say i wanna run 13 servers then i have 13 rfactor installs folder in folder 1 i copy the dedicated exe rename it to ghost so i have 2 dedicated exe:
what i also do is open 3 ports for 13 servers when do that servers can only be joined from lobby list not by ip adress .. . but it save me ports on my router :p

http://img195.imageshack.us/img195/5629/hostservers.jpg (http://img195.imageshack.us/i/hostservers.jpg/)

take a look at this picture maybe hard to understand about host many servers need a good upload so in multiplayer ini i set data to 96 kb then not my upload get so easy max .

a edited multiplayer ini file can be found here http://tripp.team-forum.net/t18-fibersserversettingsv10#19

03-09-11, 09:24 PM
I know that it goes +1 with every server instance on the same maching, but when you start another maching it goes right back to 34777 and trys to use that port again thus the time out error. any other suggestions. Besides getting a busniss service with 5 static ips. then that would fix the problem, but that costs a ton of money. let me know. Jeff

Noel Hibbard
03-10-11, 12:38 PM
mcopy... I tested what you are saying and the server starts based on the settings in your multiplayer.ini files. You need to make sure server one (regardless of what physical server it is located on) is set like this:
Query Port Start="34297"
Port Start="34397"

Then server two (again, regardless of the machine) is set like this:
Query Port Start="34298"
Port Start="34398"

The other port (34447) also increments based on "Query Port Start" and "Port Start". So if you configure the multiplayer.ini like I just said, server one will get 34447 and server two will get 34448. Again, regardless of what machine it i on. You don't have to run all the servers on one machine to get the ports to increment properly.

Double check that you have edited the correct multiplayer.ini file for each server. Double check you are editing the one under the driver profile your server is using. You are missing something somewhere. I have been running servers for a long time now in a ton of different configurations. Multiple servers on one machine. Multiple servers located on different machines behind one firewall all sharing one public IP (like you). Servers running on VMs. You name it.

Ian Johansen
03-26-12, 09:36 AM
Old thread I know...but i'm trying to get a couple of the games dedicated servers online on an older machine on mine, dual core XP OS. I have different rig i play on. I've tried setting the port forwarding as indicated above, modified the .ini files accordingly as described. ( except for what trip posted...I couldn't grasp all that, though i would like to have 4 games running eventually) Anyways, I'm trying to run Street Stock Shootout Mod (which I have another machine in the house that will actually host it, but there are others in the house that use it) and I'm trying to run the VHR mod. Both are password locked for our league. Here's what happening....
Folks can connect but as soon as they do they kicked with the message connection lost. On my end i'm getting ...

what'shisname was removed from the game:Server is not receiving updates from client

Any ideas? Ports are as follows
Application name External Port Internal port Protocol
rFactor Street Stock 34297 34299 Both (this was at 34298 same issuse)
rFactor Street Stock 34397 34399 UDP
rFactor Street Stock 34447 34449 TCP

And ini file points to these values.Then below it i have...

rFactor VHR 34298 34299 Both
rFactor VHR 34398 34399 UDP
rFactor VHR 34448 34449 TCP

and again the ini files points to the above value.
They .ini file also has the Default IP Address= to what my machine & router values are.

I have set the IP for that particular machine, and it always is assigned that the same value.

Any help would be greatly appreciate..our series is supposed to start next week and I got no clue what else i need to do to get it running. Thanks , Ian

Noel Hibbard
03-26-12, 11:49 AM
I am confused.. How do you you have a "range" set in the INI files?

Your Street Stock multiplayer.ini should look like this:
Query Port Start="34297"
Port Start="34397"
Default Game Name="Ian's Street Stock Server"

Then on your firewall you just forward 34297 (TCP/UDP), 34397 (UDP) and 34447 (TCP).

And your VHR multiplayer.ini should look like this:
Query Port Start="34298"
Port Start="34398"
Default Game Name="Ian's VHR Server"

Then on your firewall you just forward 34298 (TCP/UDP), 34398 (UDP) and 34448 (TCP).

Edit: The "Default IP Address" that you see in the Multiplayer.ini is just the last IP you typed in rFactor when trying to manually join a server. It has no effect on hosting and can be set to anything.

Ian Johansen
03-26-12, 11:16 PM
Sorry, my lack of education for the correct termanology may have caused the confusion. I meant that ini file is edited to read as you've posted above. Everything is, as you've laid out...even went through and verifiied the settings on the ini file compared to a stock version.
We still get ....was removed from the game:Server is not receiving updates from client and it's instant.
I am attempt to run the "servers' From my userdata/playername folders. The ini in the Dedicated Server folder is identical. At this point i'm lost as to whatelse to do. Sorry i know it's kinda like trying to teach a baby to talk, well that's actually easier i think..lol

Thanks again Noel , really appreciate your effort here :)

Ian Johansen
03-27-12, 03:30 PM
Also just ran the Hosting Tester and tried running the test to the default ip it had. Returns with....
Starting Winsock
Socket bind error
TCP Socket bind error
Socket setup taking too long, restart program
I got no idea what this means..lol I'll google it , but thought it might be something you guys know about .

Thanks again :)

Side note...it also returns the same script no matter which ip i use..the one i've dedicated to the machine, my ip from whatsmyip...

And i've also reset (unplugged/plugged back in) my router. The comp i've set for hosting the dedicated servers does get assigned the correct IP i've assigned rfactor Street stock to and rfactor VHR in my portforwarding. this has been confirmed 3 times now. Meaning i've told my router to give computer "xyz" a specific ip each time.

Ian Johansen
03-28-12, 02:19 AM
Just an update....
In the target line of both Desktop shortcuts, i had added +fullproc at some time ( someone else's post suggested this) After finding a similar problem listed here i removed the + fullproc from the target line and boom...both games up and running with no issues. Thanks for everyones help :)